Bug with monsters

If you find any bugs/glitches in the game, please post them here.
Post Reply
User avatar
Scias
Posts: 33
Joined: Dec 08 2017

Bug with monsters

Post by Scias » Nov 23rd, 2018, 5:21 pm

Sometimes monsters graphics seem to appear on wrong tile, I've seen Skallugs walking on water in the cave and on this screencapture I can't hit this Skallug because for some reason it was inside of me and not on the spot where it was showing to be, it also wasn't attacking me for that reason I guess.
Image

also not sure what was going on with this one:
Image

User avatar
Abi
Programmer
Posts: 156
Joined: Oct 21 2017
Location: `merica
Contact:

Re: Bug with monsters

Post by Abi » Nov 24th, 2018, 11:10 am

Check if your graphics drivers are updated. Also, what's your ping? If your ping/bandwidth is absurdly high then it's likely that your client can't keep up with the server.

User avatar
Scias
Posts: 33
Joined: Dec 08 2017

Re: Bug with monsters

Post by Scias » Nov 24th, 2018, 11:25 am

Graphic drivers are updated and ping is consistent 155ms. The bugs happen only a couple times and aren't a common occurance.

User avatar
Abi
Programmer
Posts: 156
Joined: Oct 21 2017
Location: `merica
Contact:

Re: Bug with monsters

Post by Abi » Nov 24th, 2018, 11:28 am

I'll look into this. I can probably add some sort of auto correction system which the server-client negotiates.

If anyone else is experiencing this issue feel free to comment

User avatar
demonlord5000
Posts: 13
Joined: Aug 16 2018
Location: tennessee

Re: Bug with monsters

Post by demonlord5000 » Nov 24th, 2018, 1:30 pm

Not a common occurrence for me either, but I've seen this before in two different situations. This can probably happen with any monster.

1. Sometimes when I kill a monster, the sprite doesn't disappear until that same monster respawns. From what you typed though, that doesn't seem to be the case for what happened to you.

2. Sometimes it'll glitch and a monster will be one screen over from where the sprite is displayed making it look like i'm being attacked by nothing. This seems like what happened to you in that first screenshot, and you just happened to end up on top of it.

It's a rare occurrence for me, though I think I also have like 50 ping when i'm on. It's possible it could occur more frequently for those with higher pings. At the time of this post I went on and checked and got a ping of 56.
The arena demon returns with a vengeance!

Post Reply